[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

proxy returning empty hits only in emacs

From: Sam Halliday
Subject: proxy returning empty hits only in emacs
Date: Thu, 12 Mar 2015 08:16:59 -0700 (PDT)
User-agent: G2/1.0

Hi all,

I installed Debian Jessie over Ubuntu Vervet following a kernel update disaster.

However, following the change emacs (both 24.4) is unable to make use of my 

I have a CNTLM proxy on localhost which does not require additional 
authentication, e.g.

  export http_proxy=http://localhost:3128/
  export https_proxy=https://localhost:3128/
  export no_proxy="localhost,*"
  export ftp_proxy=${http_proxy}

which is picked up by the X environment, and emacs appears to use it 
automatically because issuing a `(package-refresh-contents)` gives

  Importing package-keyring.gpg...done
  Using a proxy for http...
  Contacting host: localhost:3128
  Failed to download `gnu' archive.
  Failed to download `melpa' archive.

However I can't get any more debugging information than this, despite turning 
on (setq debug-on-error t). I'd like to know *why* it is failing so that I can 
fix it.

I also tried running url-copy-file:
  (url-copy-file "";  "google.html")

but this simply creates an empty file.

The proxy is working fine for everything else on the system (and, except for a 
few special cases, everything picks up the envvars).

I've even tried this (which is pretty pointless, because emacs is clearly using 
the correct proxy):

  (setq url-proxy-services
   '(("no_proxy" . "^\\(localhost\\|10.*\\)")
     ("http" . "localhost:3128")
     ("https" . "localhost:3128")))

as expected, it changes nothing.

Is there something else I'm missing?

Best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]