[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: <Multi_key> does not work anymore

From: Cecil Westerhof
Subject: Re: <Multi_key> does not work anymore
Date: Tue, 10 Mar 2015 19:35:59 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

Op Saturday 7 Mar 2015 16:56 CET schreef Emanuel Berg:

> Cecil Westerhof <> writes:
>>> If Emacs says "<Multi_key> is undefined" then it
>>> should be easy enough to solve this, just define
>>> (bind) it to do whatever you want. If you want it
>>> to be a key sequence probably you need to make it a
>>> "prefix key" as well, as in: ; step 1 - name
>>> (define-prefix-command 'C-o-prefix) ; step 2 - bind
>>> (global-set-key "\C-o" 'C-o-prefix) ; step 3 -
>>> normal usage as you would any key (global-set-key
>>> "\C-\M-j" 'scroll-left-1) ; ...
>> It has nothing to do with Emacs: it is done with
>> xmodmap, so it is an X binding not an Emacs binding.
>> This is something I defined years ago (globally, so
>> for normal user and root user) and always worked. I
>> did not change anything in .xnodmap or in .emacs. So
>> this should not be happening, but it is.
> If you press a key and Emacs says it is undefined that
> means Emacs recognizes a key has been pressed and it
> recognizes the key. That key sounds like it has a
> special purpose in X, so you might still run into
> problems, but why not just try bind it to whatever
> functionality you wish for it?

Because <Multi_key> is the start of a very big range of conversion. I
would not want to define them all by hand.

Problem is (probably) solved with:
    /usr/bin/env -u XMODIFIERS /usr/bin/emacs 

Cecil Westerhof
Senior Software Engineer

reply via email to

[Prev in Thread] Current Thread [Next in Thread]