[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How to point an emacs build to gif libs

From: Harry Putnam
Subject: Re: How to point an emacs build to gif libs
Date: Fri, 23 Jan 2015 10:26:36 -0500
User-agent: Gnus/5.130012 (Ma Gnus v0.12) Emacs/25.0.50 (gnu/linux)

Harry Putnam <> writes:

> Everywhere you see that word will be info telling what lib is not
> being found.  Once you know what lib... its short work to:
>   find /suspected/path/base/ -name '*lib_named_at_perhaps*'
> And thereby find the correct paths to add. to PKG_CONFIG_PATH

I may have jumped the gun before testing ... I still haven't managed
to get ./configure to accept --with-gif=yes.  In fact some of my
concoctions have broke the configure run entirely.  for example:

It really is not thoroughly explained (nor should it be) in the
install file, just how to do this.. there are examples which I tried
to follow:

 ./configure --prefix=/usr/local/src/vcs/git/test --with-x=yes\
   --with-gif=yes --with-imagemagick=yes --with-x-toolkit=athena\
     --without-sound --disable-largefile
             LDFLAGS="-L/opt/csw/lib -L/opt/csw/lib/amd64/" CFLAGS='-03'

(It's all one line on the cmd line)

Leads to a very short run of configure.. some 12-13 lines... Now it
cannot find the compiler... something it knew a  few moments
ago... somehow my illinformed flags have rendered ./configure dumber
than with no flags

  checking for xcrun... no
  checking for GNU Make... make
  checking for a BSD-compatible install... /usr/gnu/bin/install -c
  checking whether build environment is sane... yes
  checking for a thread-safe mkdir -p... /usr/gnu/bin/mkdir -p
  checking for gawk... gawk
  checking whether make supports nested variables... (cached) yes
  checking build system type... i386-pc-solaris2.11
  checking host system type... i386-pc-solaris2.11
  checking for gcc... gcc
  checking whether the C compiler works... no
  configure: error: in `/usr/local/src/vcs/git/emacs':
  configure: error: C compiler cannot create executables
  See `config.log' for more details

I've tried a few other concoctions too, which ended better than the
above run, but have yet to get configure to find the gif libs.

Again, I'm not particularly wedded to gif support... just would
finally like to know how set things up when a default ./configure run
doesn't cut it.

I've dug up some help on google and tried a run after reading a few
bits about it... it didn't wash out totally but still did not find or
use gif libs.

I believe the needed items are here:

  find /opt/csw/ -name 'include'

[...] trimmed out doco under ../share/..


Can you suggest where I might find some more detailed info about how
those flags are actually set?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]