[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: run ssh in emacs

From: Haines Brown
Subject: Re: run ssh in emacs
Date: Sat, 17 Jan 2015 15:15:41 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

Michael Albinus <> writes:

> Fix your problems with .netrc (proper permissions, maybe all entries in
> one line) and it shall work.

Michael, sorry to try your patience. Are you saying the message saying
there is a possible permissions problem with .netrc could somehow be
related to the format of its stanza? In any case. I already had tried
both inline and column format.

I need to do some kind of debug or trace on the command to see just what
is going on, but don't know how to do it.

It seems it is not just password, but the .netrc file that is not being
accessed. For example, with the line in .netrc:

  machine login Benutzer password Geheim

and accessed with command C-x -C-f /, if I understand
the manual correctly, it should log into the Benutzer account. However,
the password prompt I get is: 

    Password for

The manual suggests my account name (haines) is used if no other account
is specified. This suggests to me that ange-fpt is not seeing the login
information at all.   

A year or two ange-ftp worked. Since then I upgraded debian to Wheezy, Emacs
to emacs 24, and reorganized emacs files (not relevant now because I'm
using $ emacs -Q).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]