[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: move-beginning-of-line moves to the very beginning instead of where

From: dan
Subject: Re: move-beginning-of-line moves to the very beginning instead of where it should
Date: Wed, 31 Dec 2014 21:01:23 -0800 (PST)
User-agent: G2/1.0

Thanks Emanuel and Stefan.

Finally the problem sort of solved itself, and i'm posting just in case 
somebody else has this problem and is trawling the net for a clue like i was.

Just to recap, the problem was the control-A in the shell 
(move-beginning-of-line) would quit working for me when using emacs on the mac. 
 It would always start out working, but after a session was up for some 
time---an hour to a few days to a few weeks---it would begin misbehaving by 
going all the way to the beginning of the line, instead of stopping at the end 
of the shell prompt.

But the problem never happened on ubuntu or any other system.

I tried following some of the very good advice given here about how to debug 
the elisp code but could not get to the bottom of it.

But then somebody (Juan Leon) yesterday posted the same issue on, and somebody else (abo-abo) suggested looking at 
inhibit-field-text-motion.  And that turned out to be my problem: i had a 
function which temporarily set that variable to t, but sometimes i interrupted 
the function---and in those cases (naturally) control-A would quit working 
properly.  And it never showed up on ubuntu, because on ubuntu i had an 
alternative to that function.

So thanks again everybody!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]