[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

How to get Smart Tabs Mode to load?

From: Nate Bargmann
Subject: How to get Smart Tabs Mode to load?
Date: Mon, 29 Sep 2014 15:37:06 +0000 (UTC)
User-agent: Pan/0.139 (Sexual Chocolate; GIT bf56508 git://

I installed Smart Tabs Mode from MELPA using the Emacs package manager.  
I've followed the instructions on the older Emacs Wiki and tried some 
things from the smart-tabs-mode-readme.txt installed in ~/.emacs.d/elpa 
and neither seems to work.  Namely, any time I try calling smart-tabs-
insinuate from ~/.emacs I get an error from Emacs when starting it.  Here 
is a partial output with --debug-init:

Debugger entered--Lisp error: (void-function smart-tabs-insinuate)
  (smart-tabs-insinuate (quote c))
  eval-buffer(#<buffer  *load*> nil "/home/nate/.emacs" nil t)  ; Reading 
at buffer position 2726
  load-with-code-conversion("/home/nate/.emacs" "/home/nate/.emacs" t t)
  load("~/.emacs" t t)

I have checked the load-path and it begins with:

        ("/home/nate/.emacs.d/elpa/smart-tabs-mode-20140331.1629" ...)

I even tried the following lines from the "manual installation" 

         (autoload 'smart-tabs-mode "smart-tabs-mode"
           "Intelligently indent with tabs, align with spaces!")
         (autoload 'smart-tabs-mode-enable "smart-tabs-mode")
         (autoload 'smart-tabs-advice "smart-tabs-mode")
         (autoload 'smart-tabs-insinuate "smart-tabs-mode")

and still calling (smart-tabs-insinuate 'c) fails.

I am using Emacs 24.3 installed on Debian Unstable.

Even when I am in a C language buffer, I can enable smart-tabs-mode, but 
I see no difference with it enabled or disabled.  Perhaps I was trying it 
in the wrong place by aligning function arguments on separate lines and I 
was getting an extra tab on the second line either way.  Trying the if 
construct on the Wiki page, alignment is done with tabs and not spaces 
with Smart Tabs Mode enabled.  I am quite puzzled and a bit frustrated 
about all of this.

I have no other MELPA packages installed.


- Nate

reply via email to

[Prev in Thread] Current Thread [Next in Thread]