help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacsclient command line use existing client


From: Tory S. Anderson
Subject: Re: emacsclient command line use existing client
Date: Fri, 19 Sep 2014 13:44:58 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

Just tried the hard-coding; no change in behavior. 

Subhan Michael Tindall <address@hidden> writes:

>> -----Original Message-----
>> From: address@hidden
>> [mailto:address@hidden On
>> Behalf Of Tory S. Anderson
>> Sent: Friday, September 19, 2014 10:12 AM
>> To: Oliver Kappel
>> Cc: address@hidden
>> Subject: Re: emacsclient command line use existing client
>> 
>> *sigh* still no go. I've put the full path in the calls everywhere, and I've
>> named the server "server" instead of "emacs-client" (you were right; that
>> was one problem). When I use a shortcut that calls just the "emacs-client -c"
>> it opens, attached to "server" (with all the same buffers still available). 
>> When
>> I go to the start menu and find "emacs client", it is also working 
>> appropriately.
>> However, when I hit ~/email.so from my Firefox, it launches a new server.
>> Adding the fully qualified path, and/or "-s server" doesn't change this.
>> 
>> $ whereis emacsclient
>> emacsclient: /usr/bin/emacsclient /usr/share/man/man1/emacsclient.1.gz
>> 
>> I have only one location. Is there some reason that .so script (I could just 
>> as
>> well rename it to .sh) is opening it as a new server?
>> 
>> Running:
>> GNU Emacs 24.3.1 (x86_64-redhat-linux-gnu, GTK+ Version 3.10.9) of 2014-
>> 08-18 on buildvm-21.phx2.fedoraproject.org Fedora 20 x64 in KDE
>> 
>> << full contents of email.so >>
>> -------------------------------
>> #!/bin/sh
>> # emacs-mailto-handler
>> 
>> mailto=$1
>> mailto="mailto:${mailto#mailto:}";
>> mailto=$(printf '%s\n' "$mailto" | sed -e 's/[\"]/\\&/g')
>> emacs_server="server"
>> elisp_expr="(mailto-compose-mail \"$mailto\")"
>> 
>> /usr/bin/emacsclient -a "" -c -n -s "$emacs_server" --eval "$elisp_expr" \
>>      '(set-window-dedicated-p (selected-window) t)'
> ^^^^^^
> This line is your most obvious potential point of failure.  Have you checked 
> your running script to make sure that your variable expansion is proper?
> IE Is -s "$emacs_server" actually expanding to "server" and not say 
> ""server"" or something obnoxious like that? 
> Try hard-coding the call line to -s "server" and see what happens.
>
>
>
> This message is intended for the sole use of the individual and entity to 
> which it is addressed and may contain information that is privileged, 
> confidential and exempt from disclosure under applicable law. If you are not 
> the intended addressee, nor authorized to receive for the intended addressee, 
> you are hereby notified that you may not use, copy, disclose or distribute to 
> anyone the message or any information contained in the message. If you have 
> received this message in error, please immediately advise the sender by reply 
> email and delete the message.  Thank you.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]