help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems installing (M)ELPA packages


From: Michael Heerdegen
Subject: Re: Problems installing (M)ELPA packages
Date: Thu, 11 Sep 2014 00:46:14 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.4.50 (gnu/linux)

Stefan Monnier <address@hidden> writes:

> For this discussion, it would be helpful to have a list of known
> breakages with some analysis of why they break.  I know of one source of
> problems:
> When compiling the new package, (require 'foo) will do nothing if the
> old package also had a `foo' which is already loaded, in which case we
> end up using the old package's `foo' to compile the new package, which
> of course leads to various problems, e.g. if we use some macros from `foo'.

For helm, that is exactly the problem (and the only one I know of).
Currently, the maintainers are flooded with breakage reports due to
macro changes.

AFAICT, it is planned to enhance async so that it can perform
compilation of packages (and to use an advice to make package.el use
it.).  For helm, it is planned to let the helm package depend on
emacs-async, which should solve the problem - see
https://github.com/emacs-helm/helm/issues/617.

Michael.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]