help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: what'd I do now - babel and lilypond


From: Thorsten Jolitz
Subject: Re: what'd I do now - babel and lilypond
Date: Tue, 09 Sep 2014 08:59:48 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

Steven Arntson <address@hidden> writes:

> I'm an enthusiastic and error-prone new user of emacs (24.3.1) and
> org-babel (org 8.2.7c). I've been using lilypond mode in the context of
> org-mode documents, using the command "ly-tangle" to typeset music into
> midi and pdf files. It's been working great for the past few weeks,
> until today ...
>
> I updated some packages through the package manager, including org and
> org-plus-contrib, and now "M-x ly-" gives "[no match]" in the
> minibuffer. I didn't mess with my .emacs at all, which contains these
> lines:
>
> ;; ==== lilypond ====
> (autoload 'LilyPond-mode "lilypond-mode")
> (org-babel-do-load-languages
>   'org-babel-load-languages
>   '(
>     (emacs-lisp . t)
>     (sh t)
>     (org t)
>     (latex . t)
>     (lilypond t)))
>
> (setq ly-arrange-mode t)
> (setq ly-nix-ly-path "lilypond")
>
> I'm wondering if I put something somewhere that got clobbered when the
> new versions installed in my .emacs.d/elpa folder. Thank you, if you
> have any help for me!

No, I think lilypond-mode was fixed recently wrt the naming scheme, try
'lilypond-' or probably 'ob-lilypond-' as prefix instead of the short
but conventions breaking 'ly-'.

Or have a look into ob-lilypond.el to see how renaming was done. 

-- 
cheers,
Thorsten




reply via email to

[Prev in Thread] Current Thread [Next in Thread]