help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: viper-mode C-[ behavior change in Emacs 24.4


From: Emanuel Berg
Subject: Re: viper-mode C-[ behavior change in Emacs 24.4
Date: Thu, 31 Jul 2014 01:50:53 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

iquiw <address@hidden> writes:

> I'm using "C-[" key as ESC key in viper-mode, i.e. to
> escape from viper insert mode. It works on Emacs
> 24.3, but not on Emacs 24.3.92. Typing "C-[" just
> displays "ESC-" in minibuffer on Emacs 24.3.92.

The same for me, on

GNU Emacs 24.3.1 (x86_64-pc-linux-gnu, GTK+ Version
 3.12.2) of 2014-06-06 on barber, modified by Debian

- are you sure it worked on 24.3? (I think 24.3 and
24.3.1 are the same.)

> I found a workaround, evaluating the following code
> (from viper-catch-tty-ESC) gives expected behavior.
>
> ``` (let ((esc-binding (viper-uncatch-tty-ESC)))
> (define-key input-decode-map [?\e] `(menu-item ""
> ,esc-binding :filter viper--tty-ESC-filter))) ```

If you are using the tty, this can be solved as all of
those key issues (e.g., C-m) with the same method.
Check out these files; search for "C-[" and
"C-left-bracket". Won't work in X, of course...

http://user.it.uu.se/~embe8573/conf/remap.inc
http://user.it.uu.se/~embe8573/conf/emacs-init/console-keys.el

-- 
underground experts united


reply via email to

[Prev in Thread] Current Thread [Next in Thread]