help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Warning (initialization): Your `load-path' seems to contain


From: Sharon Kimble
Subject: Re: Warning (initialization): Your `load-path' seems to contain
Date: Wed, 18 Jun 2014 11:58:30 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3.91 (gnu/linux)

Eric Abrahamsen <address@hidden> writes:

> Ruben Maher <address@hidden> writes:
>
>> Sharon Kimble <address@hidden> writes:
>>
>>> For some time now I've been getting this -
>>> Warning (initialization): Your `load-path' seems to contain
>>> your `.emacs.d' directory: /home/boudiccas/.emacs.d/
>>> This is likely to cause problems...
>>> Consider using a subdirectory instead, e.g.: /home/boudiccas/.emacs.d/lisp
>>> in my *Warnings* buffer.
>>>
>>> These are the relevant lines from my "init.el"
>>> (setq load-path (cons "/home/boudiccas/.emacs.d/lisp" load-path))
>>> (add-to-list 'load-path "/home/boudiccas/.emacs.d/personal-lisp")
>>>
>>> Why doesn't it accept what's in the "init.el" please, and what can I
>>> do to put it right?
>>
>> Hi Sharon,
>>
>> Emacs is not rejecting init.el, it's just warning you.  If you don't
>> want to see the warning anymore you can drop this snippet in there:
>>
>> (eval-after-load "warnings"
>>   ;; shut up, emacs!
>>   '(setq display-warning-minimum-level :error))
>>
>> Kind regards,
>>
>> Ruben
>
> But the root cause still ought to be that, somewhere in your init,
> you've got (add-to-list 'load-path "/home/boudiccas/.emacs.d"). Are you
> sure you don't? I've been following emacs trunk, and a while ago got the
> same warning.
>
> I fixed it by removing ~/.emacs.d from my load path, putting
> (add-to-list 'load-path "~/.emacs.d/lisp") in my ~/.emacs.d/init.el
> file, and then putting everything I wanted to require or load underneath
> ~/.emacs.d/lisp. No warnings anymore...
>
Thanks for this Eric, this is what I ended up doing, although I was
very wary of destroying my hard-won set-up, and I did restore my
"init.el" from backup as it was so cobbled about that I couldn't see
what was loading and what wasn't! And I did have 2 instances of
(add-to-list 'load-path "~/.emacs.d") which were soon commented out!
That problem of "Warning (initialization)" has been bugging me for
months and I kept putting off dealing with it but it got embarrassing
when the task had been repeated for 84 days, and still not dealt
with! :)

But now its all pristine clean and working well, thanks folks :)

Sharon.
-- 
A taste of linux = http://www.sharons.org.uk
my git repo = https://bitbucket.org/boudiccas/dots
TGmeds = http://www.tgmeds.org.uk
Debian testing, fluxbox 1.3.5, emacs 24.3.91.1

Attachment: signature.asc
Description: PGP signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]