help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: About `char' in momentary-string-display


From: Xue Fuqiao
Subject: Re: About `char' in momentary-string-display
Date: Fri, 18 Oct 2013 15:51:25 +0800

On Fri, Oct 18, 2013 at 4:12 AM, Kai Großjohann <address@hidden> wrote:
> Xue Fuqiao wrote:
>> I tried evaluating ‘(momentary-string-display "foo" 1)’ in the *scratch*
>> buffer and typed ‘C-f’, but point didn't move forward.
>
> I think it's related to evaluation in the *scratch* buffer.  Try typing
> M-: and then eval the expession there -- it works as advertised.
>
> But how exactly the *scratch* buffer makes it fail, I'm not sure.  I
> tried to eval (previous-line 3) in the scratch buffer, and it dutifully
> went up some lines before inserting "nil" (the return value).

Thanks.  But in fact I didn't use eval-print-last-sexp (which is bound
to C-j in lisp-interaction-mode by default).  I was using eval-last-sexp
(C-x C-e).  I also tried ‘load’ and ‘eval-expression’, but neither of
them worked as I expected.

Maybe we are using different versions of Emacs?  I'm using 24.3.50
(114635 address@hidden) on Ubuntu 13.04.

-- 
Best regards, Xue Fuqiao.
http://www.gnu.org/software/emacs/



reply via email to

[Prev in Thread] Current Thread [Next in Thread]