help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: invalid-function kbd on Emacs 24.2


From: Eli Zaretskii
Subject: Re: invalid-function kbd on Emacs 24.2
Date: Sun, 10 Feb 2013 19:38:43 +0200

> From: "Drew Adams" <address@hidden>
> Cc: <address@hidden>, <address@hidden>
> Date: Sun, 10 Feb 2013 09:00:18 -0800
> 
> > > > Recall that `kbd' changed recently from a macro to a 
> > > > function.  My guess is that
> > > > that might have something to do with this.  Just a hunch.  
> > > > Maybe an old byte-compiled file is involved somehow.  
> > > 
> > > But you said 24.2 - the release, which does has `kbd' only 
> > > as a macro.
> > > 
> > > So maybe the problem is a more recent haskell library that 
> > > expects `kbd' to be a function, and so does not DTRT to get
> > > the macro `kbd' (loaded).
> > 
> > Unlikely: I tried both with 24.2 and the current development version,
> > and didn't get the error either way.
> 
> Did you try with a recent Haskell library?

I don't understand what that means.  I loaded the latest haskell-mode
and turned the mode on.  This was said to produce the error; it
didn't.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]