[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: LaTeX/Emacs problem

From: Fred Krogh
Subject: Re: LaTeX/Emacs problem
Date: Mon, 07 Jan 2013 08:25:00 -0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Thunderbird/17.0

On 01/06/2013 11:48 PM, Pierre Lorenzon wrote:


I encountered similar problems but not everytime ! With certain
files errors cannot be detected and with other ones not. It
sometimes depent on the place LaTeX is started from i.e. from
the master file or not. In fact I have not completely
identified the circumstances for which error finding
fail. Anyway I suspect that your problem is an auctex problem
and that you'd try to post on the auctex mailing list. If you
might determine more precisely when error finding fails it
might maybey help to determine where this bad behavior comes

This sounds like what I'm seeing now.

First of all, all the commands I've entered dealing with things like fmtutil-sys were run as root.

I have one short file that worked when run as root, but not as my usual user. A longer tex file never works.

I uninstalled auctex, and things worked as one might expect without auctex. The program tended to run to completion with an error message.
(I was simply inserting a command like \xxx.)

I then reinstalled auctex, and the short tex file worked very nicely with my usual user, and as root. The long tex file (the kind I care about) worked with neither.

More sleuthing, and the long tex file works if I comment out

So that is looking like the real culprit. Heiko Oberdiek is the maintainer of hyperref and if this email should reach him perhaps he will have some ideas. For his information I've added my original message.
A long time ago when I ran latex from inside emacs, if there were errors it would point me to the place with the error (maybe after <cntrl c `>?). For the last few years, when there was an error, I had to type <cntrl c `> that gave me a line number, I then had to kill that window to get back to my latex buffer, go to that line and fix the problem. Now another step backwards. After <cntrl c `> all I get now is " Error occurred after last TeX file closed". The only choice at this point seems to be running latex in a separate terminal window. I'd be interested if anyone else is having these sorts of problems, suggestions for tracking down the problem, or if you have it working perhaps your .emacs.el file? I'm running TeXLive on a gentoo linux system. Many thanks.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]