[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

tramp recursive load

From: David Rosenthal
Subject: tramp recursive load
Date: Sun, 01 Apr 2012 09:06:09 -0400

There is some discussion of this problem in May 2011, but it wasn’t helpful to me.

I’m trying to use emacs, running on a Windows machine to edit files on a remote Linux machine, using tramp.  Using v. 23.1.1 from my laptop, which has Windows 7 professional 32 bit, everything is fine.

Using 23.1.1 or other recent emacs versions from a virtual Windows 7 Enterprise (SP 1) 32 bit machine, I get the “recursive load” error.


The command I’m trying to run is /plink:<user>@<ip-address><:/home/<user>, which should get me into dired on the remote machine.


It looks as though requiring tramp loads tramp.el, which in turn requires tramp-cmds, which in turn requires tramp.  I’m guessing the fact that tramp-cmds is loaded by eval-after-load is supposed to make this work out right, but something goes wrong.


I also get the problem on 23.4, and there isn’t a later version for Windows.  I’ve also tried lots of other variants, to no avail.


I have no idea why Windows 7 Pro 32 doesn’t have the problem, but Windows 7 Enterprise 32 does.


I don’t think this is a plink problem.


I’ve also tried requiring ‘tramp in my .emacs file, and manually loading tramp or tramp-cmds.  On occasion, I’ve gotten it to work (even on Windows Enterprise) but then I can’t reproduce it.  I’d be happy with a work-around, even if I have to do some rigmarole when I start emacs.


David Rosenthal

COO, Principal


139 Billerica Rd. EB1

Chelmsford, MA 01824

Cell: 781 354-0390


reply via email to

[Prev in Thread] Current Thread [Next in Thread]