[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: edit a file over two linked ssh

From: suvayu ali
Subject: Re: edit a file over two linked ssh
Date: Tue, 22 Nov 2011 00:03:40 +0100

Hello Michael,

On Mon, Nov 21, 2011 at 20:32, Michael Albinus <address@hidden> wrote:
> You haven't said which user to apply on publichost and intgw. I assume
> publicuser and intuser. Then you could do

Sorry forgot to mention that. I have all the ssh settings in my
~/.ssh/config and tramp-default-method is set to ssh. So always I
connect like this: "C-x C-f /remotehost:/path/to/file".

> (add-to-list 'tramp-default-proxies-alist
>             '("remotehost.\+" nil "/ssh:address@hidden:"))
> (add-to-list 'tramp-default-proxies-alist
>             '("intgw" nil "/ssh:address@hidden:"))
> Note, that the order of both forms matters. Now you can open "C-x C-f
> /address@hidden:/path/to/file".

This doesn't seem to work. Whenever I do this, using ps I can see tramp
tries to connect like this: ssh -l user -e none remotehost. And
obviously the connection times out.

I tried the following in a minimal Emacs 24 session.

(require 'tramp)

(setq debug-on-quit t
      tramp-default-method "ssh"
      tramp-verbose 6)

(add-to-list 'tramp-default-proxies-alist
             '("remotehost.\+" nil "/ssh:address@hidden:"))
(add-to-list 'tramp-default-proxies-alist
             '("intgw" nil "/ssh:address@hidden:"))

Then I tried to open a file like this: C-x C-f /address@hidden:~/ RET

After waiting for a while I hit C-g to generate a backtrace (attached).

PS: I also tried using 'user' instead of %u without success.



Open source is the future. It sets us free.

Attachment: log.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]