[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gnus: Sending email from an IMAP account: "Process smtpmail not runn

From: Marius Hofert
Subject: Re: Gnus: Sending email from an IMAP account: "Process smtpmail not running"
Date: Mon, 21 Nov 2011 00:22:37 +0100

Okay, I finally figured something out:

1) I needed STARTTLS. This I could not find for Mac OS X, but it's contained in 
gnutls. I wanted to install the latest version, but that failed due to some 
missing file libnette... . I then used macports to install gnutls -- not a very 
new version, but it did the job.

2) .gnus.el [so that was correct]:
(setq send-mail-function 'smtpmail-send-it
      message-send-mail-function 'message-smtpmail-send-it
      smtpmail-smtp-server "")

3) When trying to send an email from my gmail account to my other account, I 
was asked for the user name and password. Apparently the info in .authinfo was 
not correct. Indeed, I had the full gmail address instead of just the login. So 
the correct version is (with the usual replacements):
machine login mylogin port imaps password ...
machine login port imaps password ...
machine login port smtp password ... 
=> Note the different port for

4) I also tried sending emails from my other (non-gmail) account and it worked. 

Remaining questions I have (since I'm not fully understanding what I am doing) 
1) Are there any disadvantages in using for sending emails from 
my non-gmail account? 
As far as I understood, gmail then takes care of saving sent mails [which would 
actually be good since the other account may change every once in a while]
2) How could I set up a second smtp server? Can I just add a line like 
smtpmail-smtp-server "" under 2) ?
3) What's the best way to get notified of new mail? I found:
3.1) gnus-notify.el
3.2) GnusBiff (see set up via growl 
Is there also a way to get notified via a sound?



On 2011-11-20, at 21:32 , Marius Hofert wrote:

> Dear Tassilo,
> many thanks for helping :-)
> I added the line to .authinfo and the three lines to .gnus.el. I then tried 
> to send emails from both my accounts and obtained (in both cases):
> "Sending failed: 530 5.7.0 Must issue a STARTTLS command first. 
> l18sm13222866fab.9"
> I then tried it with...
> (setq send-mail-function         'smtpmail-send-it
>        message-send-mail-function 'message-smtpmail-send-it
>        smtpmail-smtp-server       "")
> ... but obtained again "Process smtpmail not running".
> Cheers,
> Marius

reply via email to

[Prev in Thread] Current Thread [Next in Thread]