[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Displaying images does not always work - why not?

From: Nick Dokos
Subject: Displaying images does not always work - why not?
Date: Mon, 6 Jun 2011 22:53:30 +0000 (UTC)
User-agent: Loom/3.14 (

I had some trouble  with Julien Danjou's nifty google-weather and its corollary
org-google-weather (available from Julien's git repo
git://, but most of it turned out to be
some volatility in
what Google provides.

There is a remaining problem however that is driving me up the wall.
Org-google-weather downloads and displays weather information, including GIF
images (partly cloudy etc). It also caches both the information and the images
for 12 hours. When the information is displayed, sometimes the images are fine,
but most of the time they are empty boxes.

Turns out that if I defeat the caching and download the images from Google
they display properly. If I try to display a cached image, I get the
empty box. Here is what I tried:

(setq date '(6 6 2011))
(setq foo (let ((org-google-weather-cache-time 0))

(setq bar (org-google-weather))

(equal foo bar) returns t. Evaluating foo and bar in separate windows and
running compare-windows also says they are the same. Doing C-u C-x = and
clicking on the display property of each and comparing them shows no difference.

(insert foo)

displays the image, whereas

(insert bar)

displays an empty box.

I tried to reduce it to more elemental components, by saving the image part of
the cached file into a different file, called foo.gif. I can display that using
ImageMagick's "display" program (although when I open it in emacs, I get the
binary content). I converted it to a PNG, usinc convert: I can display the PNG
using "display" and I can also open it in emacs: I get the image displayed.

But when I try

(setq i (create-image "foo.png"))
(insert-image i)

I get the dreaded empty box (and the same thing with foo.gif). And btw,
image-type-available-p says t for both gif and png.

What am I missing?


PS. I tried with both emacs 24.0.50 and emacs 23.1.1 and get the same result in
this last case. If you care to try it out, I've put the foo.png file at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]