help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compatibility problem of whitespace-mode & PrettyControlL?


From: Xah Lee
Subject: Re: compatibility problem of whitespace-mode & PrettyControlL?
Date: Wed, 30 Mar 2011 10:15:54 -0700 (PDT)
User-agent: G2/1.0

On Mar 30, 9:13 am, "Drew Adams" <address@hidden> wrote:
> > there seems to be a compatibility problem with whitespace-mode and
> > both http://user42.tuxfamily.org/formfeed-hline/index.htmland
> >http://www.emacswiki.org/emacs/PrettyControlL
> > in short, when one of PrettyControlL or formfeed-hline-mode is loaded,
> > then the unicode in whitespace-mode disappears.
> ...
> > it seems when pretty print is loaded, all those triangle and
> > middle dot doesn't show. same problem happens with formfeed-hline.
> > any idea what's going on?
>
> I replied to your question on Emacs Wiki
> (http://www.emacswiki.org/emacs/PrettyControlL).  I don't know what causes the
> problem, but I can confirm it.  Perhaps someone else can help?  Sorry.

Thanks Drew.

I found that this problem is reproducible without my personal settings
on whitespace-mode and pretty-control-l-mode.

New steps to reproduce:

(1) load pretty control mode. (require 'pp-c-l)
(2) turn it on.  (pretty-control-l-mode 1)
(3) turn on global-whitespace-mode
(4) now the unicode char ( “·”, middle dot, #xb7) used to indicate
spaces are gone.

Some other interesting findings.

• turning off pretty-control-l-mode doesn't help.
• unloading it doesn't fix it neither. (unload-feature 'pp-c-l)
• the problem does not happen if you simply load pp-c-l but doesn't
turn it on. Once turned on, the problem happens and cannot be fixed by
turning off pp-c-l or unloading it.

The above are tested with pp-c-l but it happens with
http://user42.tuxfamily.org/formfeed-hline/index.html
too as i tested earlier.

 Xah


reply via email to

[Prev in Thread] Current Thread [Next in Thread]