help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: w3m-el-snapshot installation


From: Haines Brown
Subject: Re: w3m-el-snapshot installation
Date: Sat, 26 Mar 2011 19:46:37 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.2 (gnu/linux)

Michael Heerdegen <address@hidden> writes:

> Haines,
>
>> When I try to run the w3m command in an emacs session without any init
>> file, I get "[no match]".
>
> I assume you mean emacs -q.  (for emacs -Q, this would be normal).

No, by "without any init" I means with -q option. I'm not clear whether
or not the "[no match]" is proper.

>>> Use M-x locate-library w3m RET to check if your emacs uses the right
>>> w3m library. 

> If you get this for emacs -q, then indeed there's something wrong with
> your installation.

Indeed, this was the response with emacs -q and now I repeat to be
sure. Only a minor point: the sequence is a) M-x locate-library, b) RET,
c) w3m, d) No library w3m in search path. I.e., the order I used is
different).

> I would suggest to purge the "w3m-el-snapshot" package (key _ in
> aptitude), and install it again.  Please watch the output.  Does it
> say something about byte-compiling?

I purged w3m-el-snapshot and w3m and reinstalled debian squeeze
w3m-el-snapshot. In answer to your question, the w3m-el-snapshot was not
byte-compiled. Here's the end of the feedback:

  ...
  Unpacking w3m-el-snapshot (from
            .../w3m-el-snapshot_1.4.400+0.20100725-1_all.deb) ... 
  Processing triggers for menu ...
  Processing triggers for man-db ...
  Processing triggers for install-info ...
  Setting up w3m (0.5.2-9) ...
  Setting up apel (10.8-1) ...
  install/apel: byte-compiling for emacs23, logged in
           /tmp/elc.ZOMVotML0oJ0 
  install/apel: deleting /tmp/elc.ZOMVotML0oJ0
  install/apel: byte-compiling for reverse dependency
  Setting up flim (1:1.14.9+0.20100313-2) ...
  install/apel: already byte-compiled for emacs23, skipped
  install/flim: byte-compiling for emacs23, logged in
          /tmp/elc.0A1vGIUGCqTr      
  install/flim: deleting /tmp/elc.0A1vGIUGCqTr
  install/flim: byte-compiling for reverse dependency
  Setting up w3m-el-snapshot (1.4.400+0.20100725-1) ...
  install/apel: already byte-compiled for emacs23, skipped
  Processing triggers for menu ...

It looks to me that w3m, apel, flim and w3m-el-snapshot were all "set
up", but w3m-el-snapshot was not "installed: byte compiling". Nothing
followed the last line. I again tried the tests above, and results are
the same. I still do not have a /usr/share/emacs23/site-list/w3m
directory to hold the .elc files.

Haines Brown


reply via email to

[Prev in Thread] Current Thread [Next in Thread]