help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: encoding


From: rinefez
Subject: Re: encoding
Date: Mon, 14 Mar 2011 18:21:27 -0700 (PDT)
User-agent: G2/1.0

On Mar 13, 3:07 am, "Pascal J. Bourguignon" <address@hidden>
wrote:
> rinefez <address@hidden> writes:
> > My Emacs 23.2.1 in inferior-lisp entering (from italian keyboard)
>
> > #\
>
> > returns
>
> > #\LATIN_CAPITAL_LETTER_A_WITH_TILDE
>
> > which is wrong cause i entered latin small a with grave accent. In
> > fact entering
>
> > (char-code #\ )
>
> > returns 195 (the code point of ) instead of 224 (the code point of
> > ).
>
> > Anybody has a clue to how to solve this?
>
> Set the same encoding system for emacs, slime and the inferior lisp.
>
> http://common-lisp.net/project/slime/doc/html/Emacs_002dside-customiz...
>
> --
> __Pascal Bourguignon__                    http://www.informatimago.com/
> A bad day in () is better than a good day in {}.

I tried that, adding the following lines to my emacs, but it didn't
work, I still have the same problem:

(setq inferior-lisp-program "c:/home/bin/clisp/full/lisp.exe -B c:/
home/bin/clisp/full -M c:/home/bin/clisp/full/lispinit.mem -E utf-8 -
q"); my Lisp system
...
(setq slime-net-coding-system 'utf-8-unix) ; sets the coding system of
communications between SLIME and Lisp
(setq locale-coding-system 'utf-8)
(set-terminal-coding-system 'utf-8)
(set-keyboard-coding-system 'utf-8)
(set-selection-coding-system 'utf-8)
(set-default-coding-systems 'utf-8)
(prefer-coding-system 'utf-8)
(set-language-environment "UTF-8")
(swank:create-server :coding-system "utf-8-unix")

Any help is appreciated. Thanks.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]