[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ediff-revision doesn't recognize Mercurial-managed source

From: Glenn Morris
Subject: Re: ediff-revision doesn't recognize Mercurial-managed source
Date: Mon, 07 Mar 2011 14:19:05 -0800
User-agent: Gnus (, GNU Emacs (

Skip Montanaro wrote:

> While it appears that the version of GNU Emacs (23.1) I downloaded from
> has a vc-hg.el.gz file, executing vc-next-action (C-x v v) on a
> Mercurial-managed file seems to have tried to register the file with bzr!
> Trying to execute ediff-revision results in a "blah is not under version
> control" message.
> Do I need to sprinkle some sort of magic ~/.emacs magic pixie dust to get vc
> to work?

It should Just Work (though I'm not familiar with
On GNU/Linux, I tried:

hg clone my-hello

emacs-23.1 -Q my-hello/hello.c

Making changes to the file and trying vc-next-action worked fine for me.
ediff-revision also seemed to work (normally I use C-x v =).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]