help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: how to type math symbols in gnu emacs 2.12.19


From: a.efremov
Subject: Re: how to type math symbols in gnu emacs 2.12.19
Date: Thu, 17 Feb 2011 04:13:43 -0800 (PST)
User-agent: G2/1.0

On Feb 17, 10:41 am, Peter Dyballa <address@hidden> wrote:
> Am 17.02.2011 um 02:47 schrieb a.efremov:
>
> > checking for alloca... no
> > checking whether `alloca.c' needs Cray hooks... no
> > checking stack direction for C alloca... -1
> > configure: error: a system implementation of alloca is required
>
> The file config.log can give you more details.
>
> When the buffer's encoding is set to UTF-8 you can simply type the  
> maths characters on your keyboard. When you set read-quoted-char-radix  
> to 16 you can insert them by typing C-q 2 2 6 b <something not  
> hexadecimal> or C-q 1 d 7 4 a <something not hexadecimal> to insert  
> the character from this position in Unicode (U+226B or U+1D74A). UTF-8  
> support is improved in GNU Emacs 23.x.
>
> When you copy something in a modern windowing system, then not only  
> some text is copied (and this text can be copied in many different  
> coding systems) but also text attributes (bold, not upright, at 24  
> pt). And this combination is inserted by pasting it into some buffer –  
> in a different text encoding. Some customisation can be done in the  
> windowing system and some in GNU Emacs.
>
> --
> Greetings
>
>    Pete
>
> There is no national science just as there is no national  
> multiplication table; what is national is no longer science.
>                                 – Anton Checov

hello,

adding soft link definitely helps to build binary > ll /usr/lib64/
libX11.*
lrwxrwxrwx 1 root root      11 2011-02-17 12:46 /usr/lib64/libX11.so -
> libX11.so.6

emacs runs. Unicode symbols are ok on display. instead of just \xxx as
it was with emacs-22.
But. Menu doesnt work at all, emacs always pop up File-menu. then very
unfriendly black menu bar ..
address@hidden emacs-23.2]$ ldd /usr/local/bin/emacs
        linux-vdso.so.1 =>  (0x00007fffe01ff000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00000034ab000000)
        libncurses.so.5 => /lib64/libncurses.so.5 (0x0000003898a00000)
        libm.so.6 => /lib64/libm.so.6 (0x00000034a8400000)
        libc.so.6 => /lib64/libc.so.6 (0x00000034a8000000)
        libtinfo.so.5 => /lib64/libtinfo.so.5 (0x0000003898200000)
        libxcb-xlib.so.0 => /usr/lib64/libxcb-xlib.so.0
(0x00000034aac00000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00000034aa000000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00000034a8800000)
        /lib64/ld-linux-x86-64.so.2 (0x00000034a6e00000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00000034aa800000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00000034aa400000)

I have a feeling that emacs is broken and doesnt work as expected. in
my configuration. Dont know what I should look at to spot the problem.

many thanks you for help,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]