[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

gdb hangs in Emacs 23.2.1 (Mac OSX 10.6.3)

From: Dylan
Subject: gdb hangs in Emacs 23.2.1 (Mac OSX 10.6.3)
Date: Fri, 4 Feb 2011 13:37:59 -0800 (PST)
User-agent: G2/1.0

I cannot get gdb to work under Emacs 23.2.1 (neither in the GNU
command line version or Cocoa Emacs). Each time I run gdb under emacs
and then execute a command with 'RETURN', the prompt just sits there.
The version of gdb that is being executed under emacs is:
6.3.50-20050815 (Apple version gdb-1344).

So I figured I would try the latest version of gdb (7.1) as a
workaround, and installed it successfully via MacPorts. But am unable
to get emacs to recognize the executable file (fsf-gdb). I suspect
there is something wrong with my code/I am using the wrong commands.

I put the following in my .emacs, none of which worked (emacs doesn't
recognize fsf-gdb after M-x) :

(setq exec-path (append exec-path '("/opt/local/bin/fsf-
(add-to-list 'load-path "opt/local/share/gdb/syscalls")
(require 'fsf-gdb)

What am I missing here? And why might the Apple's version of gdb hang
in emacs (it works just fine in terminal)?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]