[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: dired hook not working?

From: rustom
Subject: Re: dired hook not working?
Date: Mon, 25 Jan 2010 23:20:09 -0800 (PST)
User-agent: G2/1.0

On Jan 26, 12:04 pm, rustom <address@hidden> wrote:
> I am trying to use the dired-sort options from dired-sort-menu+
> If I put the below lines in my startup the hotkey S-mouse2
> does not work (and the second print never shows up in messages though
> the first does)
> -----------
> (print "Entering dired setup")
> (defun my-dired-settings ()
>   (print "Entering my-dired-settings")
>   (require 'dired-sort-menu+))
> (add-hook 'dired-load-hook 'my-dired-settings)
> ------------
> However if I manually do eval-expression: (require 'dired-sort-menu+)
> it works.
> So either the hook is not working or I am not using it right.
> Note I tried this with emacs 22 and 23
> I also tried this with an inline lambda as well as my-dired-settings
> -- none work

Forgot to add:  also tried putting it on dired-mode-hook -- still the

reply via email to

[Prev in Thread] Current Thread [Next in Thread]