help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: yasnippet losing default snippets


From: andrea
Subject: Re: yasnippet losing default snippets
Date: Sat, 23 Jan 2010 11:57:40 +0100
User-agent: Gnus/5.110011 (No Gnus v0.11) Emacs/23.1.50 (darwin)

andrea <address@hidden> writes:

> A strange thing happened, now yasnippet is only loading my personal
> snippets and not anymore the defaults one.
> My configuration is pretty simple
>
> (require 'yasnippet)
>
> (setq yas/root-directory
>       '("~/.emacs.d/my-snippets/text-mode/"
>       "~/.emacs.d/yasnippet/snippets/"))
>
> ;; Maybe needed to set to fixed for some modes
> (setq yas/indent-line 'auto)
>
> (yas/initialize)
>
> (setq yas/ignore-filenames-as-triggers t)
>
> (mapc 'yas/load-directory yas/root-directory)
>
> ;; don't make backups in the snippet folder, they mess up yasnippet
> ;; Should this really go here?
> (add-to-list 'backup-directory-alist '("/my-snippets/" . "/tmp/"))
>
> and it always worked.
> I can see the snippets loaded from the menu and if I click on them they
> work, but if I try to expand the right keys it doesn't find any
> completion.
>
> I also tried to load only subdirectories for modes (maybe I modified
> something) but it's the same, and I don't get any error message.
> What could that be?

Strange, also updating yasnippet or just loading the default
configuration doesn't make any difference, very wierd, only my own
snippets are working...





reply via email to

[Prev in Thread] Current Thread [Next in Thread]