[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

yasnippet losing default snippets

From: andrea
Subject: yasnippet losing default snippets
Date: Sat, 23 Jan 2010 11:44:27 +0100
User-agent: Gnus/5.110011 (No Gnus v0.11) Emacs/23.1.50 (darwin)

A strange thing happened, now yasnippet is only loading my personal
snippets and not anymore the defaults one.
My configuration is pretty simple

--8<---------------cut here---------------start------------->8---
(require 'yasnippet)

(setq yas/root-directory

;; Maybe needed to set to fixed for some modes
(setq yas/indent-line 'auto)


(setq yas/ignore-filenames-as-triggers t)

(mapc 'yas/load-directory yas/root-directory)

;; don't make backups in the snippet folder, they mess up yasnippet
;; Should this really go here?
(add-to-list 'backup-directory-alist '("/my-snippets/" . "/tmp/"))
--8<---------------cut here---------------end--------------->8---

and it always worked.
I can see the snippets loaded from the menu and if I click on them they
work, but if I try to expand the right keys it doesn't find any

I also tried to load only subdirectories for modes (maybe I modified
something) but it's the same, and I don't get any error message.
What could that be?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]