help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help with doxymacs


From: Herbert J. Skuhra
Subject: Re: Help with doxymacs
Date: Mon, 18 Jan 2010 11:22:18 +0100
User-agent: Wanderlust/2.15.9 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Goj┼Ź) APEL/10.7 Emacs/23.1.91 (i686-pc-linux-gnu) MULE/6.0 (HANACHIRUSATO)

At Mon, 18 Jan 2010 00:50:54 -0800,
Suvayu Ali wrote:
> 
> Hi everyone,
> 
> Recently I came across the library doxymacs[1], but I haven't been able 
> to build the library. It relies on the GNU auto tools, and I am not 
> familiar with it. So far from what I have figured out, these are the 
> commands that I use to generate the ./configure script and the Makefile 
> for the library:
> 
> > $ autoconf
> > configure.ac:11: error: possibly undefined macro: AM_INIT_AUTOMAKE
> >       If this token and others are legitimate, please use m4_pattern_allow.
> >       See the Autoconf documentation.
> > configure.ac:18: error: possibly undefined macro: AM_PATH_LISPDIR
> > configure.ac:21: error: possibly undefined macro: AM_PATH_XML2
> > $ aclocal
> > $ automake
> > configure.ac:11: required file `./install-sh' not found
> > configure.ac:11:   `automake --add-missing' can install `install-sh'
> > configure.ac:11: required file `./missing' not found
> > configure.ac:11:   `automake --add-missing' can install `missing'
> > c/Makefile.am: required file `./depcomp' not found
> > c/Makefile.am:   `automake --add-missing' can install `depcomp'
> 
> However running ./configure gives me this error.
> 
> > $ ./configure
> > ./configure: line 1775: syntax error near unexpected token `doxymacs,'
> > ./configure: line 1775: `AM_INIT_AUTOMAKE(doxymacs, 1.8.0)'
> 
> Thanks for any help on this.

Hi! 

Why are you running autoconf/aclocal/autoconf? Have you checked out
the source from cvs?

In this case try:

% autoreconf -i
% ./configure

-Herbert






reply via email to

[Prev in Thread] Current Thread [Next in Thread]