help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Sending mail via SMTP hangs.


From: Aidan Gauland
Subject: Re: Sending mail via SMTP hangs.
Date: Thu, 14 Jan 2010 21:56:00 +1300
User-agent: Mozilla-Thunderbird 2.0.0.22 (X11/20090707)

Torsten Mueller wrote:
>> (setq smtpmail-default-smtp-server "smtp.rurallink.co.nz")
> 
> My line is (setq smtpmail-smtp-server "...")

OK, I changed mine to that.  No help.

>> (setq smtpmail-local-domain "no8wireless.co.nz")
> 
> I don't have this line.

I removed that line.  No difference.

>> (setq smtpmail-auth-credentials
>>       '(("smtp.rurallink.co.nz" 465 "address@hidden" "<secret>")))
> 
> I use an .authinfo file.

I put this in a .authinfo file.  Same behaviour.

>> (setq smtpmail-starttls-credentials
>>       '(("smtp.rurallink.co.nz" 465 nil nil)))
> 
> This is always suspicious. Are you sure your SMTP server does support
> TLS? Turn this off at least for the moment to reduce complexity.

I know it supports SSL, as I am using it with Thunderbird over SSL.

I just tried to, in the .authinfo file, and in .emacs (separately, not both at
once), tell it to use port 25 (so no encryption), but Emacs still uses
starttls and on port 465.

TLS has been succeeded by SSL, has it not?  And isn't GNUTLS considered
inferior to OpenSSL?  (I really don't know, I've just heard this around the
Internet, but haven't confirmed any of this.)

> What happens in the message buffer until you press C-g?

If I just let it run for a while this is shown in the *Messages* buffer:
Opening STARTTLS connection to `smtp.rurallink.co.nz:465'...done
[several minutes pass]
smtpmail-send-command: Process SMTP not running

I'm also using Emacs22.2.1, and I tried Emacs23, but had the exact problem.

--Aidan

Attachment: signature.asc
Description: OpenPGP digital signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]