[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Font problem with xft (solved)

From: Rainer Trusch
Subject: Re: Font problem with xft (solved)
Date: Thu, 07 Jan 2010 12:24:40 +0100
User-agent: Gnus/5.110009 (No Gnus v0.9) Emacs/23.1 (gnu/linux)

On  7 Jan 2010, Rainer Trusch wrote:

> Hi,
> A while ago I setup Emacs on my PC for ttf fonts and it works
> fine. Yesterday I did the same with my notebook. If I start it with
> emacsclient -c -a ""
> the startup breaks with this message:
> *ERROR*: Font `-adobe-Helvetica-medium-r-normal-*-*-100-*-*-*-*-iso8859-15' is
>       not defined
> No client shows up. If I start emacs the ordinary way, it starts but I
> get the error message in the mini buffer and no ttf fonts.
> The strange thing is both systems have the same setup. It is a current
> version of Debian/sid and the emacs configuration is syncronized via
> unison. The xft config is in my .Xdefaults and looks this way:
> Emacs.FontBackend: xft
> Emacs.font: DejaVu Sans Mono-11
> Emacs.geometry:120x38
> The fonts are definatly installed and I don't have any font setting in
> my emacs config. I found older bug reports with a similar problem, but
> it seemed to be fixed. It's also strange that it complains about a non
> ttf font. Has anybody a clue what to do?
> Thanks in advance
> Rainer

I just found the problem. I installed on my laptop selectable-font.el
long time ago and kept the startup in a seperat file which isn't
syncronized with my PC. I oversaw it completely since I never really
used it. Removing it does the trick.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]