help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Need help with macros


From: Pascal J. Bourguignon
Subject: Re: Need help with macros
Date: Wed, 06 Jan 2010 20:00:19 +0100
User-agent: Gnus/5.101 (Gnus v5.10.10) Emacs/22.3 (gnu/linux)

Cecil Westerhof <address@hidden> writes:

> I am trying to make some useful functionality for Gnus. I think that I
> should use a macro for that. I made the following macro (the two message
> statements are just for debugging):
>     (defmacro gnus-group-jump-bind (key-binding group-to-jump-to)
>       (message "#%s#%s#" key-binding      (type-of key-binding))

I would avoid using the character # in lisp output, since it is
meaningful (readable).

(let ((print-circle t))
  (let* ((a "hello")
         (b (list a a)))
    (print b)))
prints:
(#1="hello" #1#)

(read-from-string "(#1=\"hello\" #1#)")
--> ((#1="hello" #1#) . 16)


In a preceding message, I used "%S" instead.  You should try it!
  

>       (message "#%s#%s#" group-to-jump-to (type-of group-to-jump-to))
>       (define-key gnus-group-mode-map key-binding
>         (lambda ()
>           (interactive)
>           (gnus-group-jump-to-group group-to-jump-to))))

gnus-group-jump-bind has no need to be a macro.  As a macro it is
wrong.  Use defun!


> When calling this with:
>     (gnus-group-jump-bind "vjd" "nndraft:drafts")
>
> In the message buffer it gives:
>     #vjd#string#
>     #nndraft:drafts#string#
>
> And the return value is:
>     (lambda nil (interactive) (gnus-group-jump-to-group group-to-jump-to))
>
> This is the first problem. Outside the macro group-to-jump-to is not
> existing, I need the value of group-to-jump-to not the name itself. How
> do I do this? I tried eval, but that did not work.

By using a function instead of macro.


> But of course I do not want to set the key bindings manually but data
> driven. So I wrote the following function:
>     (defun gnus-group-do-jump-bind ()
>        (dolist (this-jump gnus-group-jump-list)
>          (let ((this-group (second this-jump))
>                (this-key   (concat "vj" (first this-jump))))
>          (gnus-group-jump-bind this-key this-group))))
>
> I defined the used value:
>     (setq gnus-group-jump-list
>           (list
>            '("d" "nndraft:drafts")
>            ))
>
> And call the function:
>     (gnus-group-do-jump-bind)
>
> This gives in the message buffer:
>     #this-key#symbol#
>     #this-group#symbol#
>     Entering debugger...
>
> And the debug output starts with:
>     Debugger entered--Lisp error: (wrong-type-argument arrayp this-key)
>
> I tried to work with symbol-value, but that did not work.
>
> What do I need to do to get this working?

Make it a function.

-- 
__Pascal Bourguignon__                     http://www.informatimago.com/


reply via email to

[Prev in Thread] Current Thread [Next in Thread]