help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Telnet Connection on Windows


From: Michael Albinus
Subject: Re: Telnet Connection on Windows
Date: Fri, 20 Nov 2009 21:57:47 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1.50 (gnu/linux)

Paul Heinrich Dietrich <address@hidden> writes:

Btw: which Emacs and Tramp versions are you running?

> Thank you for showing me something new.  Doing as you instructed allows me to
> connect.  Once in, I did:
>
>> ls -lt
>
> ...and succesfully looked at a directory, though all permissions displayed ?
> and file sizes were set to 1.  Next, I tried to see what jobs I have
> running:
>
>> ps -ef | grep me
>
> And it said:
>
> servername: remshd: Login incorrect.
> rsh: can't establish connection

That is not expected. The error message looks like there is a connection
problem to your remote host.

Could you, please, set tramp-verbose to 8, and rerun the test? There
will be a *debug tramp/...* buffer, which might be helpful.

However, I've realized, that there is also an eshell problem using pipes
on remote hosts. I'm working on this.

> But it does still seem to have the connection, because
>
>> ls
>
> works.

"ls" uses an eshell internal implementation instead of running the "ls"
command on the remote host, that's why there is a different behaviour.

> Many thanks for any feedback.

Best regards, Michael.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]