help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Using tramp from Cygwin Emacs


From: KARR, DAVID (ATTCINW)
Subject: RE: Using tramp from Cygwin Emacs
Date: Thu, 5 Nov 2009 15:02:11 -0800

> -----Original Message-----
> From: address@hidden [mailto:help-gnu-
> address@hidden On Behalf Of Harry Putnam
> Sent: Thursday, November 05, 2009 1:23 PM
> To: address@hidden
> Subject: Re: Using tramp from Cygwin Emacs
> 
> "KARR, DAVID (ATTCINW)" <address@hidden> writes:
> 
> > I believe I've tried using the Cygwin ssh, but I appear to get the
> same
> > result, even bypassing tramp.  I tried just using "eshell" and doing
> > "ssh <thehostname>" (and I'm sure that this is using Cygwin's
openssh
> > package).  After entering the password, it just redisplayed the
> password
> > prompt.  I'm using the same credentials that are working fine with
> > "putty".  It seems like this isn't an Emacs problem, or even a
Cygwin
> > problem (I can repeat the same symptom just using Putty's Plink),
but
> > perhaps something about the configuration of the SSH server.  I
don't
> > know enough about it to be sure, but my testing seems to point to
> that.
> 
> You might use the ssh with -vv and see something informative.  I've
> had problems where the remote shell login hands out stuff ssh does not
> like.  And might even cause it to fail. Its a slim chance for sure but
> might give a clue of somekind.

Well, this didn't directly help, but it made me think about this a
little more, and let me to a clue.  The login name I need to use on the
remote box is different from my local principal.  I thought I was
configuring it correctly to use that different principal, but apparently
not.  When I tried manually specifying that principal on the tramp path,
it worked fine.

So, in order to make it use that different principal automatically, I
had created $HOME/.ssh/config and chmoded 0700 on the "config" file.
The contents of the file looked like this:

Host <hostname>
HostName <hostname>
User <principaltouse>

I also set "tramp-default-method" to "ssh".

I also used "tramp-set-completion-function", using the example in the
info to make it parse my $HOME/.ssh/config file, so the resulting value
of "tramp-completion-function-alist" is:

(("ssh"
  (tramp-parse-sconfig "~/.ssh/config"))
 ("plinkx"
  (tramp-parse-putty
"HKEY_CURRENT_USER\\Software\\SimonTatham\\PuTTY\\Sessions"))
 ("sudo"
  (tramp-parse-passwd "/etc/passwd"))
 ("su"
  (tramp-parse-passwd "/etc/passwd"))
 ("telnet"
  (tramp-parse-hosts "/etc/hosts"))
 ("ftp"
  (tramp-parse-netrc "~/.netrc")))

So, for some reason, if I don't manually specify the principal to use,
it's not getting the user to use from my ".ssh/config" file.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]