[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

keyboard problem C-M-a

From: stan
Subject: keyboard problem C-M-a
Date: Thu, 5 Nov 2009 13:29:47 -0500
User-agent: slrn/ (Linux)

I have two purposes here: I'd like to get some feedback on my
thinking/troubleshooting and I'd also like to resolve the problem.

I'm using Suse 11.0 with emacs 22.2.1 and cc-mode 5.31.5. 

In c-mode, C-M-a causes no response. I tried C-h b to look at the
bindings and C-M-a is bound to c-beginning-of-defun. Here I'd like
some feedback; I'm assuming that C-h b is reading "live" keymaps and
not some prepared help text because I can see custom bindings and
furthermore, I believe that because I can see the C-M-a binding that
is is a true active binding and should work. Correct?

So then I tried C-h k thinking it would show me basically the same
thing emacs is seeing. Is that correct? Is ther a better way to see
the "raw" keyboard input that emacs is seeing when I troubleshoot
keyboard problems? I know this also shows the binding, but here I'm
considering that a side effect.

I'm running a graphical emacs so I assume that the keyboard input is
comming from X. Based on my reasoning above I'm assuming that X or
more likely KDE is possibly eating that keystroke before emacs sees
it. Does that sound right or am I missing something?

I also tried emacs -nw but I got basically the same response; the
keychord was ignored. Since I ran from a terminal emulator under X I
would expect that result if X or KDE is eating the key in route to

I have nothing in my .emacs that could cause this but to be sure I
tried starting without .emacs: same response.

Have I ruled out emacs + configuration as the problem here? Are there
obvious problems in my thinking/process/knowledge?

Has anyone else seen this and/or does anyone have any ideas on where
to start searching for the hungry keyboard bandit?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]