[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Longlines-mode and auto-save - how to debug?

From: Harald Hanche-Olsen
Subject: Longlines-mode and auto-save - how to debug?
Date: Wed, 28 Jan 2009 19:04:46 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (berkeley-unix)

I am running a fairly new CVS emacs. Lately I have started having
problems with longlines-mode: When emacs tries to auto-save the file,
I get instead this message in the minibuffer:

  Auto-saving <buffer>: Text is read-only

(where <buffer> is the actual buffer name, of course). Turning on
debug-on-error does not do anything. I tried debug-on-quit and hitting
C-g while the message is in the minibuffer, but at that point it is too
late to get a traceback.

This does not happen if I run emacs -q, so something in my .emacs
triggers it. However, my .emacs is quite large. So, before I start
bisecting it to find the cause of the problem, does anybody have any
idea what in particular I should look for, or do you have any
suggestions for getting more information?

Just to head off some unhelpful suggestions, please note it says /Text/
is read-only. We're not hit by a read-only file or directory here: This
really means that emacs is trying to change text marked read-only in
some buffer.

* Harald Hanche-Olsen     <URL:>
- It is undesirable to believe a proposition
  when there is no ground whatsoever for supposing it is true.
  -- Bertrand Russell

reply via email to

[Prev in Thread] Current Thread [Next in Thread]