[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: font handling broken in cvs emacs --with-ns (MacOS X)

From: Ian Eure
Subject: Re: font handling broken in cvs emacs --with-ns (MacOS X)
Date: Sun, 4 Jan 2009 10:52:12 -0800

On Jan 4, 2009, at 10:28 AM, B Smith-Mannschott wrote:

I've found what I believe to be a host of bugs and misbehaviors in the
font handling on Mac OS when built to use the native GUI toolkit
(--with-ns) from the current development sources. I'd like to gather
some feedback before filing a bug report. Have others observed this as

I'm running my own Cocoa builds from CVS[1]. As of the 2009/01/02 build, I'm able to change the font by:

1. Selecting an Emacs frame - in this case, containing one window with an ERC buffer visible.
2. Going to Options -> Set Default Font in the menubar.
3. Choosing Courier from the font menu.

I offer the following observations:

- Changing the default font from preferences doesn't work for me. Perhaps it sets the default, but doesn't apply it? Have you tried setting it, saving customizations, quitting and restarting Emacs?

 - Changing via Options->Set Default Font works for me.

- Changing via M-x set-default-font RET courier RET works for me. Also worked to switch back to Monaco.

Hope this helps,
 - Ian


reply via email to

[Prev in Thread] Current Thread [Next in Thread]