help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

smtpmail with tls hangs


From: Peter Rayner
Subject: smtpmail with tls hangs
Date: Fri, 29 Aug 2008 14:20:53 +0200

This is under emacs-22.1 as provided on FC-8.
Here is the relevant part of .emacs
(setq smtpmail-smtp-server "myhost.mydomain")
(setq smtpmail-smtp-service 465)
(setq smtpmail-starttls-credentials
           '(("myhost.mydomain" 465 nil nil)))

I have both gnutls-cli and starttls installed but have set
starttls-use-gnutls true so it should be  using gnutls-cli
When I send a test message it hangs after the c-c c-c ... When I kill
it with c-g  and look at the *Messages* buffer I see
Sending...
Opening STARTTLS connection to `myhost.mydomain'...done
opened connection ; this last message was an extra diagnostic I added
in smtpmail.el

The smtp trace buffer only contains the "quit" from the c-g.

If I run, from the shell
gnutls-cli myhost.mydomain -p 465
I get
220 myhost.mydomain ESMTP Postfix
and typing
EHLO myhost.mydomain
elicits the usual smtp replies. 

Anyone have any ideas either on the problem or suggestions to track it
further?
cheers
Peter
 

-- 
Peter Rayner: LSCE/IPSL, Laboratoire CEA-CNRS-UVSQ
address: Bat. 701 LSCE - CEA de Saclay
Orme des Merisiers, 91191 Gif/Yvette
work: +33  (1) 69 08 88 11;     mobile: +33 (6) 75 46 56 52;     fax: +33 (1) 
69 08 77 16
mail-to: address@hidden
web: http://www-lsce.cea.fr/Pisp/52/peter.rayner.html




reply via email to

[Prev in Thread] Current Thread [Next in Thread]