[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: won't load .emacs init file

From: paul.mead
Subject: Re: won't load .emacs init file
Date: Fri, 1 Aug 2008 02:47:51 -0700 (PDT)
User-agent: G2/1.0

On Aug 1, 9:38 am, "Lennart Borgman (gmail)"
<address@hidden> wrote:
> paul.mead wrote:
> > On Jul 31, 11:33 pm, "Lennart Borgman (gmail)"
> > <address@hidden> wrote:
> >> address@hidden wrote:
> >>> On Jul 31, 3:00 pm, address@hidden wrote:
> >>>> I'm running emacs under cygwin. For some reason my .emacs file is
> >>>> being ignored.
> >>>> The environment variable for HOME is reporting correctly as /home/
> >>>> paul. That is where I have placed my .emacs file. I have tried running
> >>>> using --debug-init and it reports no errors.
> >>>> I have evaluated every line in the file in turn and they all work
> >>>> fine. It is as if it's running emacs -q, but there are NO aliases set
> >>>> or scripts which could be running instead.
> >>>> Close to my wits' end. Can you help?
> >>>> Thanks
> >>> Additional information - running M-x load-file ~/.emacs loads the init
> >>> file perfectly, it just doesn't load when I start emacs.
> >> Do you mean that if you start with
> >>    emacs -Q
> >> then the M-x load-file ~/.emacs works?
> > No, I just srart with
> >       emacs
> > but loading the ~/.emacs file manually sets the config up ok.
> If you start with
>    emacs
> instead of
>    emacs -Q
> then there is the possibility that something in your site-start.el or
> default.el changes HOME.

Just tried that option - I get a message "Unknown option `-Q'

Using emacs -q has the usual effect (in my case no different to using
just emacs)

Using getenv, I can see that my HOME environment variable is reporting
corrcetly as /home/paul. I can't find how to get the value of user-

I don't know if this is relevant - I tried to run Customize and change
a value in there. When I tried to save changed is gave me an error
message "Saving settings from "emacs -q" would overwrite existing
customizations" - that suggests that I am using emacs -q to start, but
I'm not. There are no aliases set, is there anywhere else that a
configuration file could be hiding?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]