help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: nXhtml and RoR


From: Cezar Halmagean
Subject: Re: nXhtml and RoR
Date: Thu, 10 Jul 2008 15:44:46 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (darwin)

"Lennart Borgman (gmail)" <address@hidden> writes:

> Cezar Halmagean wrote:
>> Cezar Halmagean <address@hidden> writes:
>>
>>> "Lennart Borgman (gmail)" <address@hidden> writes:
>>>
>>>> Could you try replacing rng-valid.el with the one I have attached? You
>>>> need to byte compile it (otherwise the old version will be loaded).
>>> Still *broken*. See this screenshot:
>>> http://mixandgo.com/screen-capture.png
>>>
>>> Cezar
>>
>> Additoinal info:
>>
>> I am using GNU Emacs 23.0.60.1 (i386-apple-darwin9.2.2, *Step 9.0rc3) of
>> 2008-05-27 and I have been testing with emacs -Q also and i get the same
>> thing.
>
>
> Thanks. It might be we are hitting an Emacs bug here, I do not know.
>
> I just tested with CVS Emacs from 2008-05-29. When I open the file it
> is opened in nxhtml-mode. This is wrong, it should be opened in multi
> major mode nxhtml-mumamo.
>
> If I do
>
>   M-x nxhtml-mumamo
>
> then however the fontification works ok.
>
> So I do not get the error that you get (that is shown in the screen
> shot). Could you please show the *Messages* buffer? I hope there is
> more information.

The file opens with syntax highlighting intact but as soon as I change
something in the CSS code, the syntax gets messy again and doesn't come
back. (Try removing the ";" from "color: white;")

Using vacuous schema
(benchmark 1 '(mumamo-find-chunks))
Elapsed time: 0.004841s
Using schema ~/.elisp/nxml/nxml-mode-20041004/schema/xhtml.rnc
Internal nXML mode error in nxml-after-change (Wrong type argument:
number-or-marker-p, nil), degrading

Cezar





reply via email to

[Prev in Thread] Current Thread [Next in Thread]