help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp 2.1.13-pre messed up symbolic link?


From: Yang Zhang
Subject: Re: tramp 2.1.13-pre messed up symbolic link?
Date: Tue, 24 Jun 2008 00:24:06 -0500

Hi Michael,

Thank you for your patch. It worked fine with emacs 23 on Ubuntu 8.04.
I've also tried the patched tramp 2.1.13 with emacs 22.1 on Windows
Vista. It seems that this also allowed the Windows emacs to read and
save symbolic link files correctly on the remote Solaris 10 machine,
except for some initial warning and interactions (I have to type some
"yes" to proceed). In the Windows Vista emacs 22.1, for symbolic links
that point to cvs controlled file, it directly opened the target file
(which is fine).

There is one small issue (that I've noticed for a long time). After
saving, the target file's permission is always set to be "-rwxrwxrwx"
regardless of the original one. For example, the target file is
"test.cc (-rw-------)" the symbolic link is "test_link.cc (always
lrwxrwxrwx)"  After opening "test_link.cc" through tramp and saving
something, "test.cc" now has a permission of "-rwxrwxrwx".  It there a
way to retain the target file's original permission after saving
through the symbolic link file?

Thanks
--Yang


On Mon, Jun 23, 2008 at 5:26 AM, Michael Albinus <address@hidden> wrote:
>> Hello Michael,
>
> Hi,
>
>> Thank you for your attention and help. The pre-installed tramp
>> 2.1.13-pre with my emacs 23.0.60.1 is also having the symbolic
>> problem. Here I attached the tramp debug buffer output. The other
>> buffer "tramp /scp host*" is empty.
>
> Thanks for the traces, they have been helpful. Please try the appended
> patch (towards 2.1.14-pre), it shall fix the problem.
>
>> Thank you very much,
>>
>> --Yang
>
> Best regards, Michael.
>
>




reply via email to

[Prev in Thread] Current Thread [Next in Thread]