help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

problems configuring smtpmail-send-it


From: Tom Roche
Subject: problems configuring smtpmail-send-it
Date: Wed, 11 Jun 2008 00:05:14 -0400
User-agent: Thunderbird 2.0.0.9 (X11/20071031)


summary: I have setup Thunderbird on a host and it sends mail using
SMTP. I have Emacs setup on the same host and it does not send mail.

details:

I'm using an eee running the default version of Xandros linux, which
installed a downlevel emacs:

/home/user> emacs --version
GNU Emacs 21.4.1

It works for most purposes. The eee is running on a LAN connecting to
the internet via cable modem using DHCP: it has hostname=
eeepc-tomroche.nc.rr.com and default id=user. The eee comes with
Thunderbird, which I was able to configure to use my mail forwarder's
SMTP:

server=sasl.smtp.pobox.com
port=26
authentication=use name and password
  address@hidden
use secure connection=no

Thus configured, I can send mail from the eee using its Thunderbird
(which I'm using to send this post) ... but not emacs. I currently
have the following stanza in my .emacs:

> ;;; for mail-mode
> (setq smtpmail-default-smtp-server "sasl.smtp.pobox.com")
> ;; The variable smtpmail-default-smtp-server controls the default
> ;; hostname of the server to use. It is a string with an IP address
> ;; or hostname. It must be set before the SMTP library is loaded. It
> ;; has no effect if set after the SMTP library has been loaded, or
> ;; if smtpmail-smtp-server is defined. It is usually set by system
> ;; administrators in a site wide initialization file.
> ; try setting @ end
> (setq send-mail-function 'smtpmail-send-it)
> (setq smtpmail-smtp-server "sasl.smtp.pobox.com")
> ;; Send mail using SMTP on the mail submission port 26
> (setq smtpmail-smtp-service 26)
> ;; see
> http://www.gnu.org/software/emacs/manual/html_node/smtpmail/Authentication.html#Authentication
> (setq smtpmail-auth-credentials
>   '(("sasl.smtp.pobox.com" 26 "address@hidden"
>     "notMyPassword")))
> (setq smtpmail-sendto-domain "pobox.com")
> (setq smtpmail-local-domain nil)
> (setq smtpmail-debug-info t)
> ; try setting above
> ; (setq send-mail-function 'smtpmail-send-it)

I have tried several variants of the above, but when sending, with
`C-x m`, the following buffer

> To: address@hidden
> Subject: test sending email -nw from eee, take 7
> From: Tom Roche <address@hidden>
> --text follows this line--

> test sending email -nw from eee

I always fail with

*trace of SMTP session to sasl.smtp.pobox.com*
> 220 a-sasl-quonix.sasl.smtp.pobox.com ESMTP Postfix
> EHLO eeepc-tomroche.nc.rr.com
> 250-a-sasl-quonix.sasl.smtp.pobox.com
> 250-PIPELINING
> 250-SIZE 25165824
> 250-ETRN
> 250-STARTTLS
> 250-AUTH PLAIN LOGIN
> 250-AUTH=PLAIN LOGIN
> 250-ENHANCEDSTATUSCODES
> 250-8BITMIME
> 250 DSN
> MAIL FROM: <address@hidden> SIZE=151
> 250 2.1.0 Ok
> RCPT TO: <address@hidden>
> 450 4.1.8 <address@hidden>: Sender address rejected:
> Domain not found
> QUIT
> 221 2.0.0 Bye

What am I doing wrong? TIA, Tom Roche <address@hidden>




reply via email to

[Prev in Thread] Current Thread [Next in Thread]