help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unknown character encodings in .emacs


From: Giorgos Keramidas
Subject: Re: Unknown character encodings in .emacs
Date: Sat, 07 Jun 2008 17:04:30 +0300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (berkeley-unix)

On Sat, 7 Jun 2008 23:32:32 +1000, "Alan E. Davis" <address@hidden> wrote:
> I have stumbled on a problem in my ~/.emacs.el .  I am at a loss to even
> explain it.  It seems to me like it might be related to character encoding.
>
>
> For a number of months, or even years, I have been encountering messages
> asking what encoding I wish to use to save files.  I have gotten into the
> habit of saying "utf-8" because it gets me out of there, but I haven't a
> clue what this might do or mean.
>
> Now, my .emacs has gotten buggered.  I pasted some snippets from a web
> site.  Later one, those snippets, it seems, have gotten expressed as garbage
> characters.  I'be been poking around, but don't have a clue where to start.
> I never did understand encoding---I mean, what it does, what parts of the
> sysem are involved.  I cannot even get to first base debugging this.
>
> As an example, I have an abbreviation table that has been in my init file
> for 15 years, and now reads as gibberish.
>
> (define-abbrev-table 'global-abbrev-table '(
>     ("%`" "‚\°" nil 0)
>     ("a`" "á" nil 1)
[...]
>     ("c`" "\242" nil 0)   ;;  ¢
>     ))
>
> Can someone point me to an explanation of why this happened, and how to fix
> it?

Which Emacs version are you using?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]