help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: nxhtml-mode from OurComments.org


From: Lennart Borgman (gmail)
Subject: Re: nxhtml-mode from OurComments.org
Date: Fri, 06 Jun 2008 09:14:45 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071031 Thunderbird/2.0.0.9 Mnenhy/0.7.5.666

Tim X wrote:
Sébastien Vauban <address@hidden> writes:

Hi,

I try to use `nxhtml-mode' from OurComments.org, but I
constantly get errors -- within GNU Emacs 23, both on Ubuntu
8.04 and on Windows -- such as this one:



At a guess, I'd say that the nxhtml.el you are trying to install is
conflicting with the version that is bundled with emacs 23. Is there any
reason you want to use this version instead of the one that comes
bundled with emacs 23?

There is no nxhtml.el bundled with Emacs. It is nXml, not nXhtml, that is bundled with Emacs 23.

nXhtml is using nXml and nxml-mode is derived from nxhtml-mode.

When the load routines for nXhtml discovere that you are using a version of Emacs that includes nXml it will use the version that is included in Emacs. (Otherwise it uses the version that comes with nXhtml and is the original version from James Clark.)

If there is, what you probably need to do is make sure your locally
installed one appears in the load-path before the once bundled with
emacs.

So you should not do this. Please see above.

Tim






reply via email to

[Prev in Thread] Current Thread [Next in Thread]