help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs-cvs now can't run in zh_CN.GBK environment?


From: hong
Subject: Re: Emacs-cvs now can't run in zh_CN.GBK environment?
Date: Mon, 2 Jun 2008 18:43:54 -0700 (PDT)
User-agent: G2/1.0

On 6月2日, 下午1时08分, Jashy <address@hidden> wrote:
> hi,
>
> I am using emacs cvs version under cygwin with emacs's GBK(not mule-gbk).
>
> You can check whether mule-gbk is required in your .emacs, if yes, please
> comment it out.
>
> Below is my Chinese-GBK setting. Hope it is useful for you.
> ;; (require 'mule-gbk)
> ;; Setup GBK environment
> (set-language-environment "Chinese-GBK")
> (set-terminal-coding-system 'chinese-gbk)
> (set-keyboard-coding-system 'chinese-gbk)
> (setq locale-coding-system 'chinese-gbk)
> (setq current-language-environment "Chinese-GBK")
>
> hong-9 wrote:
>
> > I'm a slackware-current user,and using fvwm-2.5.24 with fvwm-themes as
> > my desktop.My locale is zh_cn.gbk and  inputmethod is fcitx. I can use
> > chinese language normally under slack's official emacs22 which is
> > patched with mule-gbk.Yesterday evening I build cvs version
> > successfully, but when I run "emacs" ,it fells into no response any
> > more , no window even. When I "ps aux", I found its process obtain my
> > cpu beyond 80% and I must use "kill -9" to kill it .Then I tried
> > unbuntu's snapshot ,it's the same scene.After that I tried to add a
> > test user under UTF-8 locale and found that the emacs-cvs runs very
> > well.So I decide to ask for help.Thanks.
>
> --
> View this message in 
> context:http://www.nabble.com/Emacs-cvs-now-can%27t-run-in-zh_CN.GBK-environm...
> Sent from the Emacs - Help mailing list archive at Nabble.com.

Thank you for your help. And now I figured out no matter within or
without the mule-gbk and how I set language environment. The emacs cvs
still can not at least splash a X window. the strangest thing is use
emacs in a terminal ,like "emacs -nw" ,it runs quite well ,and in a
utf-8  environment, even I use the mule-gbk setting in the .emacs, it
can still run in a Xwindow without any influence. so I gived up gbk
locale and have converted the filename to utf8 with convmv . finally
I'm using emacs-cvs in a utf-8 environment comfortably.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]