[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs-cvs now can't run in zh_CN.GBK environment?

From: Jashy
Subject: Re: Emacs-cvs now can't run in zh_CN.GBK environment?
Date: Sun, 1 Jun 2008 22:08:00 -0700 (PDT)


I am using emacs cvs version under cygwin with emacs's GBK(not mule-gbk).

You can check whether mule-gbk is required in your .emacs, if yes, please
comment it out.

Below is my Chinese-GBK setting. Hope it is useful for you. 
;; (require 'mule-gbk)
;; Setup GBK environment
(set-language-environment "Chinese-GBK")
(set-terminal-coding-system 'chinese-gbk)
(set-keyboard-coding-system 'chinese-gbk)
(setq locale-coding-system 'chinese-gbk)
(setq current-language-environment "Chinese-GBK")

hong-9 wrote:
> I'm a slackware-current user,and using fvwm-2.5.24 with fvwm-themes as
> my desktop.My locale is zh_cn.gbk and  inputmethod is fcitx. I can use
> chinese language normally under slack's official emacs22 which is
> patched with mule-gbk.Yesterday evening I build cvs version
> successfully, but when I run "emacs" ,it fells into no response any
> more , no window even. When I "ps aux", I found its process obtain my
> cpu beyond 80% and I must use "kill -9" to kill it .Then I tried
> unbuntu's snapshot ,it's the same scene.After that I tried to add a
> test user under UTF-8 locale and found that the emacs-cvs runs very
> well.So I decide to ask for help.Thanks.

View this message in context:
Sent from the Emacs - Help mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]