[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: xbindkeys and emacsclient

From: Thierry Volpiatto
Subject: Re: xbindkeys and emacsclient
Date: Wed, 30 Jan 2008 18:06:57 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux) (Joel J. Adamson) writes:

> Thierry Volpiatto <> writes:
>> (Joel J. Adamson) writes:
>>> Howdy There,
>>> Has anyone had success running Emacs commands through xbindkeys?
>>> For example:
>>> /home/joel: Zshell> emacsclient -e "(emms-pause)"
>>> works, but from my .xbindkeysrc:
>>> "emacsclient -e \"(emms-pause)\""
>>>     Mod4 + l
>>> doesn't work.  Any suggestions?
>>> I'm using Slackware Linux 12.0 and Fvwm 2.5.23.
>>> Joel
>> Did you check your keys with xev ?
>> On fluxbox i set Mod4 l (no +)
> Good question: I just tried xev and the key didn't register (the Window
> key). However, those same bindings worked with audacious, only the
> command is different.

You can use also xbindkeys -k (may be better than xev)
On ubuntu i have Mod4 == Mod4 + Super_L
So Mod4 + l is ==> Mod4 + Super_L + l
But i tried the same command than you and it didn't work.
I tried also with a script launching that command and it fail.
The command or the script work in a terminal.
I tried also with "xterm -e \"emacsclient -e \"(emms-pause)\"&"
And it fail also.
A + Thierry
Pub key:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]