help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Why I get different results running the same exp?


From: Yu,Gang
Subject: Re: Why I get different results running the same exp?
Date: Fri, 8 Jun 2007 10:57:22 +0800

If I understand you corrently, I restart emacs with

"emacs -q"

I copy the code to *scratch*, evaluate them

then, I repeatedly run "(ygrep "(start|stop)-process" "\\.el$" load-path)" third times,

first result is 128 matches , and second 141, third 146.

I ediff the buffers ,find that some items are ingored by the precedent match.

But I could not explain:-(

I suspect the problem is
"(while (and
        grep-process
        (not (equal (process-status grep-process) 'exit)))
      (sleep-for 0 100)))"

but I am not sure, any suggestions?

thanks

On 6/7/07, Thien-Thi Nguyen <address@hidden> wrote:
() "Yu,Gang" <address@hidden>
() Thu, 7 Jun 2007 19:25:28 +0800

   but, everytime I run:

   (ygrep "(start|stop)-process" "\\.el$" load-path)

   in the *scratch* buffer, I get a different result.

   What's wrong??

if you save the code and repeatedly load it into a freshly
started emacs, do you get consistent results each time?

if so, what does that mean?
if not, what does that mean?

thi
_______________________________________________
help-gnu-emacs mailing list
address@hidden
http://lists.gnu.org/mailman/listinfo/help-gnu-emacs

cheers

--
YuGang
reply via email to

[Prev in Thread] Current Thread [Next in Thread]