[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Simple function works in ver. 21.3 but not in 22.0

From: B. T. Raven
Subject: Re: Simple function works in ver. 21.3 but not in 22.0
Date: Thu, 22 Mar 2007 16:55:05 -0500
User-agent: Thunderbird (Windows/20070221)

B. T. Raven wrote:
Lennart Borgman (gmail) wrote:
Tassilo Horn wrote:
Barry Margolin <address@hidden> writes:


Does any of you know why this should not work in version 22.0 (w32)?:

(defun unfill-paragraph () ;; bound to C-x M-q
"Do the opposite of fill-paragraph; stuff all lines in the current paragraph into a single long line."
   (let ((fill-column 90002000))
     (fill-paragraph nil)))
Works for me in 22.0.50.

Works for me with 22.0.96 on GNU/Linux, too.

Works for me too on w32 with

  GNU Emacs (i386-mingw-nt5.1.2600) of 2007-03-21 (patched)

Did you try starting with

  emacs -Q

Thanks, Barry, Tassilo, and Lennart. No, emacs -Q didn't work either. I copied just the keybinding and function forms into *scratch* and evaluated them. C-h k etc. report them as loaded but they don't work. I noticed that the text ";; This buffer is for notes..." could be toggled to filled-unfilled with M-q and C-x M-q but not other text. Maybe it has to do with fontification or someething. Turnig of global fontification didn't help either though.

Build is:
This is GNU Emacs (i386-mingw-windows98.2222)of 2007-01-26 on NEUTRINO

Sorry. False alarm. The fact that it worked on a comment in lisp interactive mode was a clue. I use text mode more than 95% of the time so I didn't stop to think how useless my function would be when I tested on randomly typed strings in the context of *scratch*. As soon as I did M-x text-mode in *scratch* the function worked of course, even on the lisp code.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]