help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: eshell ls display


From: Tim X
Subject: Re: eshell ls display
Date: Fri, 15 Dec 2006 09:52:35 +1100
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.91 (gnu/linux)

Mathias Dahl <address@hidden> writes:

> Tim X <address@hidden> writes:
>
>> <address@hidden> writes:
>>
>>> When I use ls within eshell, this is what I see. 
>>> How do I get rid of the extra characters?
>>>
>>> ~ $ ls
>>> [00m[00m#.diary.cyclic-tasks#[00m
>>> [00m#.newsrc-dribble#[00m
>>> [00m#cts#[00m
>>> [00mBalanced Routing.xls[00m
>>>
>>>
>>
>> those look like ANSI color escape characters. There is an ansi-color
>> mode which will handle these appropriately. alternatively, you can
>> customize ls not do use colours. Try an apropos for ansi-color
>
> Hmm, it seems that eshell in this case does not use its internal ls,
> right? How can that happen? What happens if he tries "eshell/ls"
> instead of "ls"?

Good question. Its been many years since I had to deal with the issues
of ansi escape characters within emacs, either in a shell or with
output from colour enabled ls etc. Luckily, I now use Debian and
everything "just works". 

I'm running emacs 22 and tried both ls, /bin/ls and eshell/ls - all of
which worked correctly for me. Given that I have redefined my colour
associations, it looks like /bin/ls uses the system ls, while ls and
eshell/ls are using the eshell versions (they don't obey my customized
colour settings). 

So, I would say that either his system is using the system ls (not
sure what version of emacs or eshell he is running) or somehow his
terminal settings are screwed and don't handle ansi colour escape
codes (though I thought emacs 21 onwards default was to handle this).
Maybe the OP should try starting emacs -q to see if he gets the same
problem. If not, then its something in his .emacs that has screwed up
ansi colour support.

Tim

-- 
tcross (at) rapttech dot com dot au


reply via email to

[Prev in Thread] Current Thread [Next in Thread]