help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: No 3d modeline


From: Chris Menzel
Subject: Re: No 3d modeline
Date: Sat, 18 Nov 2006 17:03:30 +0000 (UTC)
User-agent: slrn/0.9.8.1 (FreeBSD)

On Mon, 30 Oct 2006 20:51:36 +0000 (UTC), Chris Menzel
<address@hidden> said:
> I compiled the latest xft branch of GNU emacs under both Ubuntu 6.10
> and FreeBSD 5.4 and have an identical problem with both of them.
> Everything seems to work just fine except that, instead of the usual
> 3d modeline, I'm getting a flat 2d modeline.  Moreover, occasionally,
> when I scroll down through a buffer a line or screen at a time, the
> last line of text being displayed in the buffer window will overwrite
> some or all of the modeline and I have to hit Ctrl-L to get it back.
> Along the same lines, the button widgets in the customization buffers
> are all 2d as well.  Can anyone tell me what library or libraries (or
> anything else) I might be missing that would cause this to occur?  I
> compiled with the gtk toolkit, in case that is relevant.

Just to follow up on this, I managed successfully to compile the
unicode-2 cvs branch with the gtk toolkit and xft support, obtained via:

  cvs -z3 -d:pserver:address@hidden:/cvsroot/emacs co \
  -remacs-unicode-2 emacs

The 2D problems noted above disappeared and, despite the red startup
warning about this being alpha software, it has been rock solid despite
some heavy use.  (Nonetheless, being a cautious fellow, I *have* set up
the backup options to keep a snapshot of my document with every save. :-)
The version in which I encountered the problems noted was the XFT_JHD
branch, obtained via:

  cvs -z3 -d:pserver:address@hidden:/cvsroot/emacs co emacs

and

  cd emacs ; cvs up -Pd -r XFT_JHD_BRANCH

Chris Menzel



reply via email to

[Prev in Thread] Current Thread [Next in Thread]